{"id":13461690,"url":"https://github.com/aiortc/aioquic","last_synced_at":"2026-10-19T10:15:41.370Z","repository":{"id":38287042,"uuid":"169165755","full_name":"aiortc/aioquic","owner":"aiortc","description":"QUIC and HTTP/3 implementation in Python","archived":false,"fork":false,"pushed_at":"2026-10-12T23:53:08.000Z","size":2338,"stargazers_count":2008,"open_issues_count":16,"forks_count":304,"subscribers_count":42,"default_branch":"main","last_synced_at":"2026-10-13T01:28:28.831Z","etag":null,"topics":["asyncio","http3","network","python","quic","tls"],"latest_commit_sha":null,"homepage":"","language":"Python","has_issues":true,"has_wiki":null,"has_pages":null,"mirror_url":null,"source_name":null,"license":"bsd-3-clause","status":null,"scm":"git","pull_requests_enabled":true,"icon_url":"https://github.com/aiortc.png","metadata":{"files":{"readme":"README.rst","changelog":null,"contributing":null,"funding":null,"license":"LICENSE","code_of_conduct":null,"threat_model":null,"audit":null,"citation":null,"codeowners":null,"security":"SECURITY.md","accessibility":null,"support":null,"governance":null,"roadmap":null,"authors":null,"dei":null,"publiccode":null,"codemeta":null,"zenodo":null,"notice":null,"maintainers":null,"copyright":null,"agents":null,"claude":null,"gemini":null,"cursor":null,"copilot":null,"dco":null,"cla":null,"disclosure":null}},"created_at":"2019-02-04T23:27:58.000Z","updated_at":"2026-10-12T23:52:45.000Z","dependencies_parsed_at":"2026-10-13T01:24:58.794Z","dependency_job_id":null,"html_url":"https://github.com/aiortc/aioquic","commit_stats":{"total_commits":1035,"total_committers":22,"mean_commits":47.04545454545455,"dds":0.03188405797101446,"last_synced_commit":"444be09157aed3c81881d18647484165dd07139c"},"previous_names":[],"tags_count":51,"template":false,"template_full_name":null,"purl":"pkg:github/aiortc/aioquic","repository_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/aiortc%2Faioquic","tags_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/aiortc%2Faioquic/tags","releases_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/aiortc%2Faioquic/releases","manifests_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/aiortc%2Faioquic/manifests","owner_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners/aiortc","download_url":"https://codeload.github.com/aiortc/aioquic/tar.gz/refs/heads/main","sbom_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/aiortc%2Faioquic/sbom","scorecard":{"id":173265,"data":{"date":"2025-08-11","repo":{"name":"github.com/aiortc/aioquic","commit":"218f940467cf25d364890a602b8fc451ca635062"},"scorecard":{"version":"v5.2.1-40-gf6ed084d","commit":"f6ed084d17c9236477efd66e5b258b9d4cc7b389"},"score":4,"checks":[{"name":"Maintained","score":0,"reason":"0 commit(s) and 0 issue activity found in the last 90 days -- score normalized to 0","details":null,"documentation":{"short":"Determines if the project is \"actively maintained\".","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#maintained"}},{"name":"Dangerous-Workflow","score":10,"reason":"no dangerous workflow patterns detected","details":null,"documentation":{"short":"Determines if the project's GitHub Action workflows avoid dangerous patterns.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#dangerous-workflow"}},{"name":"Code-Review","score":2,"reason":"Found 5/23 approved changesets -- score normalized to 2","details":null,"documentation":{"short":"Determines if the project requires human code review before pull requests (aka merge requests) are merged.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#code-review"}},{"name":"Token-Permissions","score":0,"reason":"detected GitHub workflow tokens with excessive permissions","details":["Warn: no topLevel permission defined: .github/workflows/issues.yml:1","Warn: no topLevel permission defined: .github/workflows/tests.yml:1","Info: no jobLevel write permissions found"],"documentation":{"short":"Determines if the project's workflows follow the principle of least privilege.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#token-permissions"}},{"name":"Binary-Artifacts","score":10,"reason":"no binaries found in the repo","details":null,"documentation":{"short":"Determines if the project has generated executable (binary) artifacts in the source repository.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#binary-artifacts"}},{"name":"Pinned-Dependencies","score":0,"reason":"dependency not pinned by hash detected -- score normalized to 0","details":["Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/issues.yml:10: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/issues.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:9: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:10: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:23: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:24: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:40: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: third-party GitHubAction not pinned by hash: .github/workflows/tests.yml:41: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:61: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:62: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: third-party GitHubAction not pinned by hash: .github/workflows/tests.yml:89: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:96: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:97: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:105: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:131: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:132: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:150: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:159: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: GitHub-owned GitHubAction not pinned by hash: .github/workflows/tests.yml:160: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: third-party GitHubAction not pinned by hash: .github/workflows/tests.yml:166: update your workflow using https://app.stepsecurity.io/secureworkflow/aiortc/aioquic/tests.yml/main?enable=pin","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:17","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:29","Warn: chocoCommand not pinned by hash: .github/workflows/tests.yml:76","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:82","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:83","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:102","Warn: pipCommand not pinned by hash: .github/workflows/tests.yml:147","Info:   0 out of  16 GitHub-owned GitHubAction dependencies pinned","Info:   0 out of   3 third-party GitHubAction dependencies pinned","Info:   0 out of   6 pipCommand dependencies pinned","Info:   0 out of   1 chocoCommand dependencies pinned"],"documentation":{"short":"Determines if the project has declared and pinned the dependencies of its build process.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#pinned-dependencies"}},{"name":"CII-Best-Practices","score":0,"reason":"no effort to earn an OpenSSF best practices badge detected","details":null,"documentation":{"short":"Determines if the project has an OpenSSF (formerly CII) Best Practices Badge.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#cii-best-practices"}},{"name":"Security-Policy","score":0,"reason":"security policy file not detected","details":["Warn: no security policy file detected","Warn: no security file to analyze","Warn: no security file to analyze","Warn: no security file to analyze"],"documentation":{"short":"Determines if the project has published a security policy.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#security-policy"}},{"name":"Vulnerabilities","score":10,"reason":"0 existing vulnerabilities detected","details":null,"documentation":{"short":"Determines if the project has open, known unfixed vulnerabilities.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#vulnerabilities"}},{"name":"Fuzzing","score":0,"reason":"project is not fuzzed","details":["Warn: no fuzzer integrations found"],"documentation":{"short":"Determines if the project uses fuzzing.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#fuzzing"}},{"name":"License","score":10,"reason":"license file detected","details":["Info: project has a license file: LICENSE:0","Info: FSF or OSI recognized license: BSD 3-Clause \"New\" or \"Revised\" License: LICENSE:0"],"documentation":{"short":"Determines if the project has defined a license.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#license"}},{"name":"Signed-Releases","score":-1,"reason":"no releases found","details":null,"documentation":{"short":"Determines if the project cryptographically signs release artifacts.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#signed-releases"}},{"name":"Branch-Protection","score":0,"reason":"branch protection not enabled on development/release branches","details":["Warn: branch protection not enabled for branch 'main'"],"documentation":{"short":"Determines if the default and release branches are protected with GitHub's branch protection settings.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#branch-protection"}},{"name":"Packaging","score":10,"reason":"packaging workflow detected","details":["Info: Project packages its releases by way of GitHub Actions.: .github/workflows/tests.yml:155"],"documentation":{"short":"Determines if the project is published as a package that others can easily download, install, easily update, and uninstall.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#packaging"}},{"name":"SAST","score":0,"reason":"SAST tool is not run on all commits -- score normalized to 0","details":["Warn: 0 commits out of 29 are checked with a SAST tool"],"documentation":{"short":"Determines if the project uses static code analysis.","url":"https://github.com/ossf/scorecard/blob/f6ed084d17c9236477efd66e5b258b9d4cc7b389/docs/checks.md#sast"}}]},"last_synced_at":"2025-08-16T17:06:57.055Z","repository_id":38287042,"created_at":"2025-08-16T17:06:57.055Z","updated_at":"2025-08-16T17:06:57.055Z"},"host":{"name":"GitHub","url":"https://github.com","kind":"github","repositories_count":344872684,"owners_count":38354515,"icon_url":"https://github.com/github.png","version":null,"created_at":"2022-05-30T11:31:42.601Z","updated_at":"2026-10-03T21:59:58.778Z","status":"online","status_checked_at":"2026-10-19T02:00:06.414Z","response_time":53,"last_error":null,"robots_txt_status":"success","robots_txt_updated_at":"2025-07-24T06:49:26.215Z","robots_txt_url":"https://github.com/robots.txt","online":true,"can_crawl_api":true,"host_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub","repositories_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories","repository_names_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repository_names","owners_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners"}},"keywords":["asyncio","http3","network","python","quic","tls"],"created_at":"2024-07-31T11:00:52.703Z","updated_at":"2026-10-19T10:15:41.364Z","avatar_url":"https://github.com/aiortc.png","language":"Python","funding_links":[],"categories":["HarmonyOS","Python","语言资源库","框架和开源实现","Implementations"],"sub_categories":["Windows Manager","python","Python"],"readme":"aioquic\n=======\n\n.. image:: https://img.shields.io/pypi/l/aioquic.svg\n   :target: https://pypi.python.org/pypi/aioquic\n   :alt: License\n\n.. image:: https://img.shields.io/pypi/v/aioquic.svg\n   :target: https://pypi.python.org/pypi/aioquic\n   :alt: Version\n\n.. image:: https://img.shields.io/pypi/pyversions/aioquic.svg\n   :target: https://pypi.python.org/pypi/aioquic\n   :alt: Python versions\n\n.. image:: https://github.com/aiortc/aioquic/workflows/tests/badge.svg\n   :target: https://github.com/aiortc/aioquic/actions\n   :alt: Tests\n\n.. image:: https://img.shields.io/codecov/c/github/aiortc/aioquic.svg\n   :target: https://codecov.io/gh/aiortc/aioquic\n   :alt: Coverage\n\n.. image:: https://readthedocs.org/projects/aioquic/badge/?version=latest\n   :target: https://aioquic.readthedocs.io/\n   :alt: Documentation\n\nWhat is ``aioquic``?\n--------------------\n\n``aioquic`` is a library for the QUIC network protocol in Python. It features\na minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.\n\n``aioquic`` is used by Python opensource projects such as `dnspython`_,\n`hypercorn`_, `mitmproxy`_ and the `Web Platform Tests`_ cross-browser test\nsuite. It has also been used extensively in research papers about QUIC.\n\nTo learn more about ``aioquic`` please `read the documentation`_.\n\nWhy should I use ``aioquic``?\n-----------------------------\n\n``aioquic`` has been designed to be embedded into Python client and server\nlibraries wishing to support QUIC and / or HTTP/3. The goal is to provide a\ncommon codebase for Python libraries in the hope of avoiding duplicated effort.\n\nBoth the QUIC and the HTTP/3 APIs follow the \"bring your own I/O\" pattern,\nleaving actual I/O operations to the API user. This approach has a number of\nadvantages including making the code testable and allowing integration with\ndifferent concurrency models.\n\nA lot of effort has gone into writing an extensive test suite for the\n``aioquic`` code to ensure best-in-class code quality, and it is regularly\n`tested for interoperability`_ against other `QUIC implementations`_.\n\nFeatures\n--------\n\n- minimal TLS 1.3 implementation conforming with `RFC 8446`_\n- QUIC stack conforming with `RFC 9000`_ (QUIC v1) and `RFC 9369`_ (QUIC v2)\n   * IPv4 and IPv6 support\n   * connection migration and NAT rebinding\n   * logging TLS traffic secrets\n   * logging QUIC events in QLOG format\n   * version negotiation conforming with `RFC 9368`_\n- HTTP/3 stack conforming with `RFC 9114`_\n   * server push support\n   * WebSocket bootstrapping conforming with `RFC 9220`_\n   * datagram support conforming with `RFC 9297`_\n\nInstalling\n----------\n\nThe easiest way to install ``aioquic`` is to run:\n\n.. code:: bash\n\n    pip install aioquic\n\nBuilding from source\n--------------------\n\nIf there are no wheels for your system or if you wish to build ``aioquic``\nfrom source you will need a C compiler and the Python development headers.\n\nOn Debian/Ubuntu run:\n\n.. code-block:: console\n\n   sudo apt install python3-dev\n\nRunning the examples\n--------------------\n\n`aioquic` comes with a number of examples illustrating various QUIC usecases.\n\nYou can browse these examples here: https://github.com/aiortc/aioquic/tree/main/examples\n\nLicense\n-------\n\n``aioquic`` is released under the `BSD license`_.\n\n.. _read the documentation: https://aioquic.readthedocs.io/en/latest/\n.. _dnspython: https://github.com/rthalley/dnspython\n.. _hypercorn: https://github.com/pgjones/hypercorn\n.. _mitmproxy: https://github.com/mitmproxy/mitmproxy\n.. _Web Platform Tests: https://github.com/web-platform-tests/wpt\n.. _tested for interoperability: https://interop.seemann.io/\n.. _QUIC implementations: https://github.com/quicwg/base-drafts/wiki/Implementations\n.. _cryptography: https://cryptography.io/\n.. _BSD license: https://aioquic.readthedocs.io/en/latest/license.html\n.. _RFC 8446: https://datatracker.ietf.org/doc/html/rfc8446\n.. _RFC 9000: https://datatracker.ietf.org/doc/html/rfc9000\n.. _RFC 9114: https://datatracker.ietf.org/doc/html/rfc9114\n.. _RFC 9220: https://datatracker.ietf.org/doc/html/rfc9220\n.. _RFC 9297: https://datatracker.ietf.org/doc/html/rfc9297\n.. _RFC 9368: https://datatracker.ietf.org/doc/html/rfc9368\n.. _RFC 9369: https://datatracker.ietf.org/doc/html/rfc9369\n","project_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Faiortc%2Faioquic","html_url":"https://awesome.ecosyste.ms/projects/github.com%2Faiortc%2Faioquic","lists_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Faiortc%2Faioquic/lists"}