{"id":13650289,"url":"https://github.com/lextudio/pysnmp","last_synced_at":"2025-10-20T16:08:42.298Z","repository":{"id":63111581,"uuid":"562745461","full_name":"lextudio/pysnmp","owner":"lextudio","description":"Python SNMP library","archived":false,"fork":true,"pushed_at":"2024-04-21T05:30:43.000Z","size":4632,"stargazers_count":53,"open_issues_count":13,"forks_count":10,"subscribers_count":6,"default_branch":"main","last_synced_at":"2024-05-01T11:38:33.671Z","etag":null,"topics":[],"latest_commit_sha":null,"homepage":"https://www.pysnmp.com/pysnmp/","language":"Python","has_issues":true,"has_wiki":null,"has_pages":null,"mirror_url":null,"source_name":"etingof/pysnmp","license":"bsd-2-clause","status":null,"scm":"git","pull_requests_enabled":true,"icon_url":"https://github.com/lextudio.png","metadata":{"files":{"readme":"README.md","changelog":"CHANGES.txt","contributing":null,"funding":null,"license":"LICENSE.rst","code_of_conduct":null,"threat_model":null,"audit":null,"citation":null,"codeowners":null,"security":null,"support":null,"governance":null}},"created_at":"2022-11-07T07:00:39.000Z","updated_at":"2024-04-21T05:30:46.000Z","dependencies_parsed_at":"2023-09-23T18:55:07.549Z","dependency_job_id":"d2604c06-bd01-4839-b7f1-97d560a6e8b9","html_url":"https://github.com/lextudio/pysnmp","commit_stats":{"total_commits":1984,"total_committers":36,"mean_commits":"55.111111111111114","dds":0.233366935483871,"last_synced_commit":"002474a06f0383870ca28e73de6727eaa0d91431"},"previous_names":[],"tags_count":31,"template":false,"template_full_name":null,"repository_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/lextudio%2Fpysnmp","tags_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/lextudio%2Fpysnmp/tags","releases_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/lextudio%2Fpysnmp/releases","manifests_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/lextudio%2Fpysnmp/manifests","owner_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners/lextudio","download_url":"https://codeload.github.com/lextudio/pysnmp/tar.gz/refs/heads/main","host":{"name":"GitHub","url":"https://github.com","kind":"github","repositories_count":223903082,"owners_count":17222487,"icon_url":"https://github.com/github.png","version":null,"created_at":"2022-05-30T11:31:42.601Z","updated_at":"2022-07-04T15:15:14.044Z","host_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub","repositories_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories","repository_names_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repository_names","owners_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners"}},"keywords":[],"created_at":"2024-08-02T02:00:35.600Z","updated_at":"2025-10-20T16:08:42.280Z","avatar_url":"https://github.com/lextudio.png","language":"Python","funding_links":["https://github.com/sponsors/lextudio"],"categories":["Libraries","Recently Updated"],"sub_categories":["Python","[Oct 31, 2024](/content/2024/10/31/README.md)"],"readme":"\nSNMP Library for Python\n=======================\n\n[![Become a Sponsor](https://img.shields.io/badge/Become%20a%20Sponsor-lextudio-orange.svg?style=for-readme)](https://github.com/sponsors/lextudio)\n[![PyPI](https://img.shields.io/pypi/v/pysnmp.svg)](https://pypi.python.org/pypi/pysnmp)\n[![PyPI Downloads](https://img.shields.io/pypi/dd/pysnmp)](https://pypi.python.org/pypi/pysnmp/)\n[![Python Versions](https://img.shields.io/pypi/pyversions/pysnmp.svg)](https://pypi.python.org/pypi/pysnmp/)\n[![GitHub license](https://img.shields.io/badge/license-BSD-blue.svg)](https://raw.githubusercontent.com/lextudio/pysnmp/master/LICENSE.rst)\n\nThis is a pure-Python, open source and free implementation of v1/v2c/v3\nSNMP engine distributed under 2-clause\n[BSD license](https://www.pysnmp.com/pysnmp/license.html).\n\nFeatures\n--------\n\n* Complete SNMPv1/v2c and SNMPv3 support based on IETF RFC standards.\n* SMI framework for resolving MIB information and implementing SMI\n  Managed Objects\n* Complete SNMP entity implementation\n* USM Extended Security Options support (3DES, 192/256-bit AES encryption)\n  based on draft standards and vendor implementations.\n* Extensible network transports framework (UDP/IPv4, UDP/IPv6)\n* Asynchronous socket-based IO API support\n  via [asyncio](https://docs.python.org/3/library/asyncio.html) integration\n* [PySMI](https://www.pysnmp.com/pysmi/) integration for dynamic MIB\n  compilation\n* Built-in instrumentation exposing protocol engine operations\n* Python eggs and py2exe friendly\n* 100% Python, works with Python 3.9+\n* MT-safe (if SnmpEngine is thread-local)\n\nFeatures, specific to SNMPv3 model include:\n\n* USM authentication (MD5/SHA-1/SHA-2) and privacy (DES/AES) protocols\n  (RFC3414, RFC7860)\n* View-based access control to use with any SNMP model (RFC3415)\n* Built-in SNMP proxy PDU converter for building multi-lingual\n  SNMP entities (RFC2576)\n* Remote SNMP engine configuration\n* Optional SNMP engine discovery\n* Shipped with standard SNMP applications (RFC3413)\n\nDownload \u0026 Install\n------------------\n\nThe PySNMP package is freely available for download from\n[PyPI](https://pypi.python.org/pypi/pysnmp) and\n[GitHub](https://github.com/lextudio/pysnmp.git).\n\nJust run:\n\n```bash\n$ pip install pysnmp\n```\n\nTo download and install PySNMP along with its dependencies:\n\n* `pyasn1` package from [PyASN1](https://pyasn1.readthedocs.io)\n* If `pysmi` package from [PySMI](https://www.pysnmp.com/pysmi/) presents,\n  MIB services are enabled.\n* If `cryptography` package (43.0.x and above) presents, strong SNMPv3 encryption is enabled.\n\nMake sure you check out other sibling projects of PySNMP from\n[the home page](https://www.pysnmp.com/).\n\nDocumentation\n-------------\n\nPySNMP documentation is hosted at the [docs site](https://www.pysnmp.com/pysnmp/).\n\n* Copyright (c) 1999-2020, [Ilya Etingof](https://lists.openstack.org/pipermail/openstack-discuss/2022-August/030062.html)\n* Copyright (c) 2022-2025, [LeXtudio Inc.](mailto:support@lextudio.com)\n* Copyright (c) 1999-2025, [Other PySNMP contributors](https://github.com/lextudio/pysnmp/THANKS.txt)\n\nAll rights reserved.\n","project_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Flextudio%2Fpysnmp","html_url":"https://awesome.ecosyste.ms/projects/github.com%2Flextudio%2Fpysnmp","lists_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Flextudio%2Fpysnmp/lists"}