{"id":21038159,"url":"https://github.com/moparisthebest/jdnsproxy","last_synced_at":"2025-08-09T00:22:09.503Z","repository":{"id":56300380,"uuid":"119644903","full_name":"moparisthebest/jDnsProxy","owner":"moparisthebest","description":"Simple fast and lightweight DNS proxy and cache, implementing DNS-over-TLS, DNS-over-HTTPS, and Serve-Stale","archived":false,"fork":false,"pushed_at":"2022-12-15T23:53:10.000Z","size":89,"stargazers_count":27,"open_issues_count":5,"forks_count":7,"subscribers_count":4,"default_branch":"master","last_synced_at":"2023-03-12T07:27:51.855Z","etag":null,"topics":[],"latest_commit_sha":null,"homepage":"","language":"Java","has_issues":true,"has_wiki":null,"has_pages":null,"mirror_url":null,"source_name":null,"license":"mit","status":null,"scm":"git","pull_requests_enabled":true,"icon_url":"https://github.com/moparisthebest.png","metadata":{"files":{"readme":"readme.md","changelog":null,"contributing":null,"funding":null,"license":"LICENSE.txt","code_of_conduct":null,"threat_model":null,"audit":null,"citation":null,"codeowners":null,"security":null,"support":null}},"created_at":"2018-01-31T06:28:15.000Z","updated_at":"2022-10-10T17:42:37.000Z","dependencies_parsed_at":"2023-01-29T06:00:42.622Z","dependency_job_id":null,"html_url":"https://github.com/moparisthebest/jDnsProxy","commit_stats":null,"previous_names":[],"tags_count":null,"template":null,"template_full_name":null,"repository_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/moparisthebest%2FjDnsProxy","tags_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/moparisthebest%2FjDnsProxy/tags","releases_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/moparisthebest%2FjDnsProxy/releases","manifests_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/moparisthebest%2FjDnsProxy/manifests","owner_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners/moparisthebest","download_url":"https://codeload.github.com/moparisthebest/jDnsProxy/tar.gz/refs/heads/master","host":{"name":"GitHub","url":"https://github.com","kind":"github","repositories_count":225360375,"owners_count":17462185,"icon_url":"https://github.com/github.png","version":null,"created_at":"2022-05-30T11:31:42.601Z","updated_at":"2022-07-04T15:15:14.044Z","host_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub","repositories_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories","repository_names_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repository_names","owners_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners"}},"keywords":[],"created_at":"2024-11-19T13:29:44.757Z","updated_at":"2024-11-19T13:29:45.306Z","avatar_url":"https://github.com/moparisthebest.png","language":"Java","funding_links":[],"categories":[],"sub_categories":[],"readme":"jDnsProxy\n---------\n\n[![Build Status](https://ci.moparisthe.best/job/moparisthebest/job/jDnsProxy/job/master/badge/icon%3Fstyle=plastic)](https://ci.moparisthe.best/job/moparisthebest/job/jDnsProxy/job/master/)\n\nSimple fast and lightweight DNS proxy and cache that listens on TCP or UDP ports and relays the request\nto various upstream [DNS-over-TCP](https://tools.ietf.org/html/rfc1035), [DNS-over-TLS](https://tools.ietf.org/html/rfc7858),\nor [DNS-over-HTTPS](https://tools.ietf.org/html/draft-hoffman-dns-over-https) servers, optionally over http or socks \nproxies (like tor), and optionally pinning public keys for complete TLS security.  Implements a simple \nresponse cache respecting TTLs but also implementing proper [Serve-Stale](https://tools.ietf.org/html/draft-ietf-dnsop-serve-stale) functionality.\n\nThis should support any current and future DNS record generically, as well as providing full DNSSEC support if upstream\nresolvers do.\n\nSample/default configuration is in [jdnsproxy.properties](https://github.com/moparisthebest/jDnsProxy/blob/master/jdnsproxy.properties) and should be documented clearly there.\n\nBuild/run like so:\n```\nmvn clean package\njava -jar jDnsProxy/target/jDnsProxy.jar ./jdnsproxy.properties\n\n# or with xmpp:// listener+resolver support:\njava -jar xmpp-dox/target/xmpp-dox-full.jar ./xmpp-dox/jdnsproxy.xmpp.resolver.properties\n\n# or with http:// listener support:\njava -jar http-doh-listener/target/http-doh-listener-full.jar ./jdnsproxy.properties\n\n# or with support for *everything* we support in this repo (other jars we don't know about can also add additional protocol support)\njava -jar jDnsProxy-all/target/jDnsProxy-all.jar ./jdnsproxy.properties\n```\n\nImplemented specs:\n\n  * [RFC-1035: DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION](https://tools.ietf.org/html/rfc1035)\n  * [RFC-7858: Specification for DNS over Transport Layer Security (TLS)](https://tools.ietf.org/html/rfc7858)\n  * [RFC 8484: DNS Queries over HTTPS (DoH)](http://tools.ietf.org/html/rfc8484)\n  * [Draft: Serving Stale Data to Improve DNS Resiliency](https://tools.ietf.org/html/draft-ietf-dnsop-serve-stale)\n  * [RFC-6891: Extension Mechanisms for DNS (EDNS(0))](https://tools.ietf.org/html/rfc6891)\n  * [DNS EDNS0 Option Codes (OPT)](https://www.iana.org/assignments/dns-parameters/dns-parameters.xhtml#dns-parameters-11)\n  * [RFC-3225: Indicating Resolver Support of DNSSEC](https://tools.ietf.org/html/rfc3225)\n  * [XEP-0418: DNS Queries over XMPP (DoX)](https://xmpp.org/extensions/xep-0418.html)\n\nUse these for quick testing:\n```\ndig -p5353 @127.0.0.1 debian.org +tries=1 +retry=0 +tcp\ndig -p5353 @127.0.0.1 debian.org +tries=1 +retry=0 +tcp +dnssec\n\ndig -p5353 @127.0.0.1 debian.org +tries=1 +retry=0\ndig -p5353 @127.0.0.1 debian.org +tries=1 +retry=0 +dnssec\n```\n\nAnd use this to extract TLS public keys in pinning format:\n```\nopenssl s_client -connect 'dns.google.com:443' 2\u003e\u00261 \u003c /dev/null | sed -n '/-----BEGIN/,/-----END/p' | openssl x509 -noout -pubkey | openssl asn1parse -noout -inform pem -out /dev/stdout | openssl dgst -sha256 -binary | openssl base64\n```\n\nLicense\n-------\nMIT License, refer to LICENSE.txt\n","project_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Fmoparisthebest%2Fjdnsproxy","html_url":"https://awesome.ecosyste.ms/projects/github.com%2Fmoparisthebest%2Fjdnsproxy","lists_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Fmoparisthebest%2Fjdnsproxy/lists"}