{"id":47203971,"url":"https://github.com/ryanplasma/sigma-pipeline-contentctl","last_synced_at":"2026-03-13T13:39:11.571Z","repository":{"id":250020160,"uuid":"833207458","full_name":"ryanplasma/sigma-pipeline-contentctl","owner":"ryanplasma","description":"This is an experimental sigma-cli pipeline file to convert a sigma rule into Splunk's contentctl yaml format","archived":false,"fork":false,"pushed_at":"2024-07-30T12:04:05.000Z","size":6,"stargazers_count":0,"open_issues_count":0,"forks_count":0,"subscribers_count":1,"default_branch":"main","last_synced_at":"2024-07-30T15:11:41.628Z","etag":null,"topics":[],"latest_commit_sha":null,"homepage":null,"language":null,"has_issues":true,"has_wiki":null,"has_pages":null,"mirror_url":null,"source_name":null,"license":"mit","status":null,"scm":"git","pull_requests_enabled":true,"icon_url":"https://github.com/ryanplasma.png","metadata":{"files":{"readme":"README.md","changelog":null,"contributing":null,"funding":null,"license":"LICENSE","code_of_conduct":null,"threat_model":null,"audit":null,"citation":null,"codeowners":null,"security":null,"support":null,"governance":null,"roadmap":null,"authors":null,"dei":null,"publiccode":null,"codemeta":null}},"created_at":"2024-07-24T15:06:27.000Z","updated_at":"2024-07-30T12:04:08.000Z","dependencies_parsed_at":"2024-07-24T19:33:07.171Z","dependency_job_id":"a08193b7-3a73-4407-b4a8-4f12c068c2b2","html_url":"https://github.com/ryanplasma/sigma-pipeline-contentctl","commit_stats":null,"previous_names":["ryanplasma/sigma-pipeline-contentctl"],"tags_count":0,"template":false,"template_full_name":null,"purl":"pkg:github/ryanplasma/sigma-pipeline-contentctl","repository_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/ryanplasma%2Fsigma-pipeline-contentctl","tags_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/ryanplasma%2Fsigma-pipeline-contentctl/tags","releases_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/ryanplasma%2Fsigma-pipeline-contentctl/releases","manifests_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/ryanplasma%2Fsigma-pipeline-contentctl/manifests","owner_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners/ryanplasma","download_url":"https://codeload.github.com/ryanplasma/sigma-pipeline-contentctl/tar.gz/refs/heads/main","sbom_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories/ryanplasma%2Fsigma-pipeline-contentctl/sbom","scorecard":null,"host":{"name":"GitHub","url":"https://github.com","kind":"github","repositories_count":286080680,"owners_count":30467807,"icon_url":"https://github.com/github.png","version":null,"created_at":"2022-05-30T11:31:42.601Z","updated_at":"2026-03-13T11:00:43.441Z","status":"ssl_error","status_checked_at":"2026-03-13T11:00:23.173Z","response_time":60,"last_error":"SSL_connect returned=1 errno=0 peeraddr=140.82.121.6:443 state=error: unexpected eof while reading","robots_txt_status":"success","robots_txt_updated_at":"2025-07-24T06:49:26.215Z","robots_txt_url":"https://github.com/robots.txt","online":false,"can_crawl_api":true,"host_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub","repositories_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repositories","repository_names_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/repository_names","owners_url":"https://repos.ecosyste.ms/api/v1/hosts/GitHub/owners"}},"keywords":[],"created_at":"2026-03-13T13:39:11.266Z","updated_at":"2026-03-13T13:39:11.548Z","avatar_url":"https://github.com/ryanplasma.png","language":null,"funding_links":[],"categories":[],"sub_categories":[],"readme":"# sigma-pipeline-contentctl\nThis is an experimental [pySigma](https://github.com/SigmaHQ/pySigma)/[sigma-cli](https://github.com/SigmaHQ/sigma-cli) pipeline file using [sigma query postprocessing](https://blog.sigmahq.io/introducing-query-post-processing-and-output-finalization-to-processing-pipelines-4bfe74087ac1) to convert a sigma rule into Splunk's [contentctl](https://github.com/splunk/contentctl) yaml format.\n\n## How To Use\nRequirements:\n* pySigma \u003e= 0.10\n\nThis pipeline file can be integrated into your existing Sigma to Splunk conversion process. For example heres how it could be used with sigma-cli:\n\n`sigma convert -t splunk -p splunk_cim -p path/to/your/pipelines/splunk_contentctl_pipeline.yml -f data_model sigma/rules/windows/process_creation/proc_creation_win_susp_recon.yml`\n\nwhich will output this:\n\n```\nParsing Sigma rules  [####################################]  100%\nname: Recon Information for Export with Command Prompt\nid: aa2efee7-34dd-446e-8a37-40790a66efd7\nversion: 1\ndate: 2021-07-30\nauthor: frack113\ndata_sources:\n- UPDATE\ntype: UPDATE\nstatus: validation\ndescription: Once established within a system or network, an adversary may use automated techniques for collecting internal data.\nkind: UPDATE\nsearch: '| tstats summariesonly=false allow_old_summaries=true fillnull_value=\"null\" count min(_time) as firstTime max(_time) as lastTime from datamodel=Endpoint.Processes where Processes.process_path IN (\"*\\\\tree.com\", \"*\\\\WMIC.exe\", \"*\\\\doskey.exe\", \"*\\\\sc.exe\") OR Processes.original_file_name IN (\"wmic.exe\", \"DOSKEY.EXE\", \"sc.exe\") Processes.parent_process IN (\"* \u003e %TEMP%\\\\*\", \"* \u003e %TMP%\\\\*\") by Processes.process Processes.dest Processes.process_current_directory Processes.process_path Processes.process_integrity_level Processes.original_file_name Processes.parent_process Processes.parent_process_path Processes.parent_process_guid Processes.parent_process_id Processes.process_guid Processes.process_id Processes.user | `drop_dm_object_name(Processes)` | convert timeformat=\"%Y-%m-%dT%H:%M:%S\" ctime(firstTime) | convert timeformat=\"%Y-%m-%dT%H:%M:%S\" ctime(lastTime) '\nhow_to_implement: UPDATE_HOW_TO_IMPLEMENT\nknown_false_positives:\n- Unknown\nreferences:\n- https://github.com/redcanaryco/atomic-red-team/blob/f339e7da7d05f6057fdfcdd3742bfcf365fee2a9/atomics/T1119/T1119.md\ntags:\n  analytic_story:\n  - UPDATE_STORY_NAME\n  asset_type: UPDATE asset_type\n  confidence: UPDATE value between 1-100\n  impact: UPDATE value between 1-100\n  message: UPDATE message\n  mitre_attack_id:\n  - UPDATE\n  observable:\n  - name: UPDATE\n    type: UPDATE\n    role:\n    - UPDATE\n  product:\n  - Splunk Enterprise\n  - Splunk Enterprise Security\n  - Splunk Cloud\n  required_fields:\n  - UPDATE\n  risk_score: UPDATE (impact * confidence)/100\n  security_domain: UPDATE\n  cve:\n  - UPDATE WITH CVE(S) IF APPLICABLE\ntests:\n- name: True Positive Test\n  attack_data:\n  - data: https://github.com/splunk/contentctl/wiki\n    sourcetype: UPDATE SOURCETYPE\n    source: UPDATE SOURCE\n```\n\nFrom here you can update the necessary fields and add it to your contentctl powered repo. \n\n## FAQ\n* Why a yaml file and not an addition to the splunk plugin?\n    *  This was easier and more flexible but in the future I could see it being an additional output format \n\n* Why do I need to update so many fields?\n  * I wanted to keep this as generic as possible so that it would fit into any workflow. \n\n","project_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Fryanplasma%2Fsigma-pipeline-contentctl","html_url":"https://awesome.ecosyste.ms/projects/github.com%2Fryanplasma%2Fsigma-pipeline-contentctl","lists_url":"https://awesome.ecosyste.ms/api/v1/projects/github.com%2Fryanplasma%2Fsigma-pipeline-contentctl/lists"}