Ecosyste.ms: Awesome

An open API service indexing awesome lists of open source software.

Awesome Lists | Featured Topics | Projects

https://github.com/santosh2702/find-a-string

solution
https://github.com/santosh2702/find-a-string

python3

Last synced: 14 days ago
JSON representation

solution

Awesome Lists containing this project

README

        

# Find-a-string

In this challenge, the user enters a string and a substring. You have to print the number of times that the substring occurs in the given string. String traversal will take place from left to right, not from right to left.

### NOTE: String letters are case-sensitive.

### Input Format

The first line of input contains the original string. The next line contains the substring.

### Constraints

1<=len(string)<=200

Each character in the string is an ascii character.

### Output Format

Output the integer number indicating the total number of occurrences of the substring in the original string.

### Sample Input

ABCDCDC

CDC

#Sample Output

2

### SOLTUTION

import re

word=input()

substr=input()

print(len([m.start() for m in re.finditer('(?='+substr+')', word)]))